Degraded performance in EU

Incident Report for Thought Industries

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 05:39 EDT

Monitoring

Platform is stable again. Continuing to monitor
Posted Oct 06, 2025 - 05:23 EDT

Identified

Possible issue with caching, but mostly transient.
Posted Oct 06, 2025 - 05:23 EDT

Investigating

Some parts of the site are still slow. Investigating.
Posted Oct 06, 2025 - 05:00 EDT

Monitoring

Platform is stable again. Continuing to monitor
Posted Oct 06, 2025 - 04:56 EDT

Identified

No specific cause, just intermittent slowness.
Posted Oct 06, 2025 - 04:56 EDT

Investigating

We are currently investigating this issue.
Posted Oct 06, 2025 - 04:47 EDT
This incident affected: EU - Platform.