Broken images across the site

Incident Report for Thought Industries

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 07:57 EST

Monitoring

A fix has been implemented and we are monitoring the platform.
Posted Jan 20, 2026 - 07:24 EST

Update

We are continuing to work on a fix for this issue.

Also, apart from broken images, all other functionality is still working as expected.
Posted Jan 20, 2026 - 06:37 EST

Update

We are continuing to work on a fix for this issue.

Also, apart from broken images, all other functionality is still working as expected.
Posted Jan 20, 2026 - 05:34 EST

Identified

The issue has been identified and we are working on fixing it.
Posted Jan 20, 2026 - 04:40 EST
This incident affected: US - Platform and EU - Platform.