System Responsiveness Being Investigated
Incident Report for Thought Industries
Resolved
The site slowness and responsiveness of the application has been resolved.

An RCA will be made available upon request within 7 business days. Please submit a support ticket to request this RCA if necessary.
Posted May 22, 2023 - 10:15 EDT
Investigating
We have identified an issue which causing a slowness to the responsiveness to the application. We are urgently working to resolve the issue.
Posted May 22, 2023 - 09:30 EDT
This incident affected: US - Platform.