Oct 27, 2025 Incident

Incident Report for Thought Industries

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 18:43 EDT

Update

We are continuing to investigate this issue.
Posted Oct 27, 2025 - 15:20 EDT

Investigating

We’re aware of an issue that’s currently affecting parts of the platform. Our Engineering team is reviewing the situation and working diligently to resolve it. Updates will be posted here as they become available.
Posted Oct 27, 2025 - 15:15 EDT
This incident affected: US - Platform.