Cloudflare Outage

Incident Report for Thought Industries

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 01:12 EDT

Update

We are working with Cloudflare support to resolve this issue.
Posted Apr 29, 2026 - 01:01 EDT

Investigating

We have detected and are investigating a Cloudflare-related issue.
Posted Apr 29, 2026 - 00:25 EDT
This incident affected: US - Platform and EU - Platform.