Investigating availability issue in US

Incident Report for Thought Industries

Postmortem

Between 13:15 and 17:08 UTC on 2025-08-25, users of the TI platform experienced slower than normal response times due to an internal scaling issue. The component which controlled internal DNS resolution failed to scale under load, resulting in higher-than-expected response times at peak traffic. The infrastructure team identified the root cause and manually scaled the DNS resolvers, restoring response times to expected levels. An update will shortly be applied to enable auto-scaling for this internal component, ensuring that this issue does not re-occur.

We apologize for the inconvenience and are committed to ensuring improved reliability going forward.

Posted Aug 28, 2025 - 13:55 EDT

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 13:15 EDT

Monitoring

A fix has been implemented and we are monitoring the situation.
Posted Aug 25, 2025 - 13:08 EDT

Update

We are continuing to investigate this issue.
Posted Aug 25, 2025 - 12:21 EDT

Update

We are continuing to investigate this issue.
Posted Aug 25, 2025 - 11:18 EDT

Investigating

Investigating high latency, and some scorm issues.
Posted Aug 25, 2025 - 10:36 EDT
This incident affected: US - Platform.