Cloudflare outage affecting some customers

Incident Report for Thought Industries

Resolved

Cloudflare services are now operating normally and the impact to Thought Industries is resolved.
Posted Nov 18, 2025 - 13:34 EST

Update

Cloudflare is reporting their services are now operating normally. We will continue to monitor for any further issues with the Thought Industries platform.
Posted Nov 18, 2025 - 13:22 EST

Monitoring

A fix has been implemented by Cloudflare and they believe the incident to be resolved, however they are continuing to monitor.

https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 10:12 EST

Update

Cloudlfare issues still persist. Cloudlfare has indentified the issue and a fix is being implemented. Cloudlfare are continuing working on restoring service for application services customers.

https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 09:00 EST

Update

Cloudflare issues still persist. Cloudflare are continuing to investigate: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 07:52 EST

Investigating

Cloudflare is aware of, and investigating an issue which potentially impacts multiple customers. Some Thought Industries customers are impacted.
Posted Nov 18, 2025 - 07:04 EST
This incident affected: US - Platform and EU - Platform.