Issue Investigation
Incident Report for Thought Industries
Resolved
We have resolved the issue and can confirm full functionality has been restored
Posted Oct 16, 2020 - 14:44 EDT
Investigating
Thought Industries is investigating possible intermittent slowdowns and will provide updates as soon as they are available
Posted Oct 16, 2020 - 14:12 EDT
This incident affected: US - Platform.